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Introduction 
Climate change is a significant challenge facing humans. On the one hand we need to address the 
issues that are exacerbating the warming process, and on the other we need to develop lifestyle 
related products that would help mitigate the effects. Thermophysiological comfort is critical to 
human performance and is significantly affected by the warming planet. New materials for housing, 
clothing and protection from harsh elements are being developed. However, significant costs 
associated with the industrial design and development process stifle equitable development i.e. not 
all communities have access or are able to afford these technologies, even though the effects of 
climate change are universal. 
 
Computer simulations may help in reducing these costs and in identifying material suitable for specific 
applications, and population specific requirements. Development of mathematical models to 
characterize comfort, the interaction between humans and materials have been an active area of 
research. Consequently, there are several models in published literature addressing various aspects 
of thermophysiological comfort. Our experience with implementing some of these models showed 
that the models and the results in the publications could not always be reproduced. Some issues 
include typographical errors in the formulae, missing parameters or the need to drill down to 
publications whose access required subscription, and some old papers used different terminology, 
units etc. There are a few free tools that are available, however, there isn't an open source software 
tool that integrates relevant models and enables the study of comfort under various environmental, 
clothing and radiative heat flux exposure conditions for realistic human geometries and body 
constitutions. 
 
We believe this gap limits the potential for exploring and developing novel solutions, especially it 
restricts domain experts who do not have access to such commercial software or have the technical 
know-how to develop the models into useful software. The Auckland Bioengineering Institute (ABI) 
Comfort Simulator is a user friendly, free, open-source tool that enables the simulation of 
thermoregulation on realistic human geometries for various environmental, body constitution and 
metabolic activity levels. 
 
This user manual describes the features of the tool and outlines the steps to setup an experiment, 
simulate, and visualize it. 
  

http://comfort.cbe.berkeley.edu/
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Organising projects 
 

Workspaces 
Often files related to experiments are organised in certain folders. Additionally, parameters associated 
with simulation, visualization etc. may also vary across projects. Users may also connected to multiple 
servers to perform simulations, in such cases the connection parameters will vary with the server. The 
notion of workspaces enables the user to collate and store these characteristics, such that all 
experiments created with respect to a workspace can access these characteristics seamlessly. 
 
Users can select a workspace, associated with a directory, at the time of launching the application. 
New workspaces can be created by selecting new directories. 
Key elements stored within a workspace include: 

1. The last successful file operation directory, 
2. List of recent projects, 
3. Number of simulation time steps per activity record (larger number may increase simulation 

time), 
4. Animation rate, 
5. Whether to use a server for simulation , 
6. Uri for accessing the server, 
7. Port number for communicating with the server, 
8. Whether to use the simplified (65MN) model or full model. 

 
Item 1 and 2 are automatically updated based on the last successful file operation 
Items 3,4,5,6,7 can be modified through Help->Preferences option 
Item 8 can be modified through the Simulation-> Project To Standard Model option 
 

Experiment setup 
 
A simulation experiment, at minimum requires an activity profile and a realistic human geometry. 

Activity profile specification 
Activity profile consists one or more records, where each record provides 

1. Ambient temperature (in Celsius), 
2. Ambient Relative Humidity (%), 
3. Metabolic activity level (mets), 
4. Magnitude of velocity of air (m/s), 
5. Description of clothing (or lack of it), (filename) 
6. Description of radiative heat flux (or lack of it), (filename) 
7. Duration (in seconds) for which these conditions are active, 

 
The activity designer interface is designed to create an activity profile. The activity designer can be 
accessed through Experiment Setup -> Create New Activity Profile. If an activity profile has been 
loaded, the activity profile can be edited through Experiment Setup -> Edit Activity Profile. 
The interface allows for loading existing activities and saving activity profiles. A screenshot of the 
activity designer with four activity records is shown below 



 

Realistic human geometry 
A realistic human geometry along with body constitution data which includes Height (in m), Weight 
(in kg), Age (years), Gender, Cardiac Index, Cardiac Aging Ratio, Sex based Metabolic Ratio is also 
required. 
 

Generating realistic human geometry 
Realistic human geometries can be created using the makehuman software tool. A nude human model 
is necessary, additionally a teeth base is required. The teeth base is necessary to determine parts of 
the head that belong to the face. The typical makehuman workflow (in version 1.1) involves 

1. Create the geometry for the target individual using the “Modelling” tab, 
2. Select the Geometries Tab and select the ‘Teeth base’, 
3. Select the Pose/Animate Tab and select the ‘Cmu mb’ rig preset, 
4. Select Files Tab and then the Export subtab. Select Collada options under the ‘Mesh Format’ 

options tab and export the file, 
5. Import the mesh file in Blender (delete all other items in the scene prior to importing), 
6. Export the mesh as a Wavefront obj file, ensure that you select the ‘Polygroups’ option in 

‘Export Obj’ toolbar.  
 

Poses can be created, especially for specifying radiative heat fluxes. Poses (like sitting in a car) can be 
created using Blender (with the help of the rig) and then the mesh can be exported as in step 6. 
 

http://www.makehumancommunity.org/


Clothing resistance specification 
Clothing provides thermal and evaporative resistance, which influences thermoregulation and 
comfort. Clothing often involves multiple layers of different fabrics. The clothing designer interface 
enables the user to define these layers and related fabric’s thermal and evaporative resistance. 
Currently the user can specify different layers of clothing for major segments of the body. The 
interface assumes symmetry, i.e. right and left (hands, arms things…) use the same fabric.  
Layers are numbered 0,..n with layer 0 being closest to the body and is expected to be skin’s resistance 
values. Additional layers can be created by 1) specifying the layer number, followed by 2) specifying 
the resistance values, and finally, 3) selecting the ‘Set Layer’ option. A layer can be removed by 
selecting the layer in the tree and then selecting the ‘Remove Later’ option. 
Note: The ‘Set Layer’ option should be clicked to save any changes. 
 
By default, a new instance of a clothing resistance project will have a SKIN layer as the first layer. The 
values for thermal and evaporative resistance of the skin with respect to the speed of the surrounding 
air is populated. Only for the skin/0th layer, the resistance values are automatically calculated based 
on the speed of surrounding air. Thus changing the speed will change these values. ‘Set Layer’ should 
be clicked to save any changes. 
 
When a fabric’s resistance values are provided, the fabric’s name can be associated with these values 
for reuse to avoid re-entry, using ‘Save Fabric’ option. Existing associations can be found using the 
‘Load Fabric’ option, which will list the fabric names and their associated resistance values. When a 
fabric is selected from this list, the resistance values are populated for the layer.  
The clothing description should be saved using the ‘Save’ option. Existing clothing descriptions can be 
loaded using the ‘Load’ option for modification. A screenshot of the clothing designer with a 
representative clothing mesh and specification of two layers for the hand is shown (Here it is assumed 
that the target individual is wearing a merino base layer glove). 
 

 

 

Radiative heat flux specification 
Radiative heat can significantly affect comfort, unlike ambient heat it is directional and affects 
different parts of the body based on their orientation to the source. Typical sources include the sun, 
radiative heaters, reflective materials etc. Radiative heat flux incident on the target individual can be 
specified using the radiative heat flux designer interface. The interface requires a realistic human 



geometry that has the same mesh-face topology as the mesh used for simulation. Ideally, this would 
be the same mesh but with a different pose (animated using blender and exported to Wavefront obj 
format).  
Once the mesh is loaded, directional sources can be specified. The centroid of the mesh is considered 
the origin of a spheroidal coordinate system. Directional sources can then be specified based on their 
distance from the mesh, the latitude and longitude. The intensity of the source is also required.  The 
source values are in kW/m2. The calculated values are shown in W/m2. 
 
Sources are graphically rendered as spheres and colours can be assigned to identify them. To handle 
sources that are very far, the interface clips the longest rendered distance to be 10 times the bounding 
box of the target mesh. The actual distance value is used for computing the incident flux using the 

inverse square law 𝐼 =
𝑖𝑛𝑡𝑒𝑛𝑠𝑖𝑡𝑦

𝑑2
⁄  and the orientation of the mesh face with the source. 

Addition/modification/removal of sources results in the recomputing of the incident flux values and 
the updated flux values are used to texture the target mesh. 
Users can zoom, rotate, translate the mesh using a combination of mouse and keyboard inputs. 

 Left mouse button press and move for rotation, 

 Right mouse button press and pan will zoom in or zoom out, 

 Shift + Left mouse button press and move for translation. 
The meshview can be reset to show all the graphical elements by clicking the viewAll tool button  
The origin can be shown or hidden using the axis tool button . 

tool button . The light sources can be show or hidden using the light state 
 

Sources can be added or removed using the add and remove tool buttons .  
To remove a source, any element in the row corresponding to the source should be clicked prior to 
clicking the remove tool button. 
 
User’s can save the scene description in terms of the sources, their intensity and position using the 
‘Save source’ option. The flux values can be saved using ‘Save Flux’ option. This is the file that should 
be used in activity definition to define the radiative heat flux profile. 
New meshes can be loaded using the ‘Load Mesh’ option and an existing scene description can also 
be loaded using the ‘Load Source’ option. A screenshot the radiative heat flux designer with a target 
human geometry and two sources is shown below. 

 



Simulation 
Prior to starting a simulation, the target individual’s geometry (Loaded using File -> Open Mesh) and 
the activity profile (Loaded using File -> Open Activity) are required. 
A particular configuration of activity profile and target geometry can be saved as an unsolved project 
file. The project could be loaded later on to be submitted for simulation or to be modified. 
 
Depending on the preference settings (Help -> Preferences), options to Start, Pause, and Stop a 
simulation or to submit the job to a server, and query the status of submitted jobs will be provided. 
By default, the simulation using a server option is disabled. 
Further, the option to use the reduced 65MN model or the realistic geometry to simulate is also 
provided (Simulation -> Project To Standard Model). 
 
In the non-server based simulation mode, the results of the simulation are loaded once it completes. 
The experiment configuration and results can be saved as a project file and reloaded later. The results 
of the simulation can also be saved separately (Simulation -> Save simulation). Past solutions can also 
be loaded (Simulation -> Load simulation). However, the user must ensure that the number of degrees 
of freedom in the current mesh and those of the results being loaded match. 
 
In the server based simulation mode, the user must manually Query the server to determine the status 
of the simulation job. The query results show the current progress level and if complete the progress 
is 100%. When a simulation is completed, the simulation can be downloaded as a project and loaded 
to visualize the results.  
Currently, the server does not remove completed jobs from its database, it is a good practice for the 
user to remove the job once the results have been downloaded.  
 
Job identification information is stored in the workspace, if the workspace is different, jobs submitted 
through a different workspace to the same server will not be accessible. 

Visualization  
Simulation results can be visualized using the main window. The skin-, core-temperature, predicted 
amount of skin wettedness,  thermal and evaporative resistance values can be rendered on the mesh 
by selecting the appropriate radio buttons. 
 
The weighted-mean skin and core temperatures for each of the 16 body segments can also be plotted, 

the plot colour can be chosen using the ‘Temperature by Anatomy’ Controls. To show a plot, the  

button should be clicked. If the plot is already shown, the  tool button should be clicked to hide 
it. All the anatomy related plots are collated in a single plot. The plot widget allows the user to export 
the data for analysis outside the tool. 
Further the mean-skin, core- and rectal-temperatures for the target geometry can also be plotted. The 
predicted mean vote and predicted percentage dissatisfied comfort scores can be plotted or hidden 
by checking the appropriate check boxes. Screenshot of rendering an experiment and its simulation 
results is shown below. 
 
The plots allow of scrolling and panning. To reset plot view to view all contents, click on A graphic 
element that appears at the bottom left corner of the plot. Similarly, to reset the human geometry 
view to be centred on the window, click the ‘Reset Mesh View’ button. 



 
 

Simulation server 
The server component for remote simulation of jobs takes an optional port number as an argument. 
The default port is 5570. The tcp ip address of the computer on which the server is started is the ip 
address on which the service is made available, the administrator is required to ensure that network 
access and firewall restrictions are appropriately handled. 
 
Clients require the tcp ip address along with the port number to communicte with the server. 
The server creates two files: thermoregulationResults.sqlite and thermoregulationProgress.sqlite in 
the directory where it was launched. These files are used to store results and progress information. 
The server does not have options to clear or track the age of these records and expects the clients to 
remove simulations that have completed or failed. Deleting these files, would destroy all related 
information. 

Installation 
The code is compatible with python 3.6. The tool relies on dependencies which are expected to be 
available in the host python environment (both the client and the server). 
 

Installation Instructions 
Download opencmiss zinc library from the development releases for the target operating system 
The binaries can be found at 
http://opencmiss.org/downloads.html#/package/opencmisslibs/devreleases 
 
Install/Extract the archive and determine the python binding version that has been provided. 
Look into the OpenCMISS-Libraries<VERSION>/lib directory 
If the directory python3.6 exists then zinc bindings for python 3.6 exists 
 (note that python 3.6 bindings will not work in python 3.7) 

Install Python  
(you can use an existing python distribution, ensure the packages are installed through appropriate 
installers) 
 



miniconda 3.6 

Install dependencies 
conda install pyqt=5 
conda install scipy json  
conda install -c conda-forge diskcache pyqtgraph 
pip install sqllitedict  
 

Install/Link with opencmiss-zinc 
Zinc can be installed by executing 
python setup.py install  
from the OpenCMISS-Libraries<VERSION>/lib/python3/Release/opencmiss.zinc/ 
 
Alternatively, this library can be linked through PYTHONPATH 

in bash 
export PYTHONPATH=OpenCMISS-
Libraries<VERSION>/lib/python3/Release/opencmiss.zinc/:$PYTHONPATH 
 

in windows 
set  PYTHONPATH=OpenCMISS-
Libraries<VERSION>\lib\python3\Release\opencmiss.zinc\;%PYTHONPATH% 

Sample meshes and projects 
 
Sample realistic human geometry meshes have been provided in the Configurations\meshes folder 
femalesuit.obj, femaleSuitWithHat.obj,malesuit.obj and infantClothes.obj are meshes that are 
intended to be used in the clothing designer. The remaining meshes can be used for simulation. 
 
Sample activity definitions have been provided in the Configurations\activities folder 
 
activities.json provides a sample activities definition profile. 
Clothing.json provides a sample clothing definition file (it is used by the above activities definition) 
noclothing.json  provides a sample nude human definition file (values could be modified for disease 
conditions) 
 
Solved project files are also available at https://models.physiomeproject.org/workspace/583 (they 
have been hosted separately due to their size).  
emptyMale.p2.pkl, solvedSimplifiedMale.p3.pkl and solvedFullFemaleModel.p3.pkl are project files 
that can be loaded into the tool. Note that these projects have been solved using python 3.6 and will 
not load if your instance is running on python 2.7. 
 
 


